Some scripts doesn't play properly via

Hi, I recently noticed that some script doesn’t play properly via, but will play normally if I connect my handy via intiface. I am using ScriptPlayer but the issue also exists if played on directly.

This script, for example. There is no action until 00:30 when it suddenly starts to sync with the video and moves up. This behaviour is fairly consistent.
山江ぶっかけ Ver.2.0.funscript (2.1 KB)
Script source:

There’s also this script which does not result in any movement at all.
MMD - Haku Wet Handjob and Deepthroat.funscript (1.9 KB)

Once these scripts starts playing, handy will move to the lowest point, then make a few rather tiny stuttering noise. I have one occasion where handy’s LED light pulses red (indication of obstacle irrc) playing these scripts.

This is particularly odd because both script looks perfectly fine in OFS. And they will play properly if connected using intiface.

1 Like

i personally stopped using Wifi on my handy because especially on larger scripts it can crash easily.
Also i think the led turns red if the movement is too fast? Had the same experience with fullspeed scripts for Abzero when syncing via wifi.
Bluetooth and intiface are the way to go, never had issues with sync nor with disconnects.

I also have had a couple of issues in the past few weeks with some scripts not working via handyfeeling. Interestingly, some scripts work on scriptplayer with the handyfeeling connection but will not work directly on the handyfeeling playground or via HereSphere. These scripts worked previously but randomly stopped and now gives an upload error.

I haven’t had time to test it again this recently, but it has been an ongoing issue. I should actually test them via initface to see whether this is a handyfeeling problem or not.

These scripts are fairly brief and slow so the speed shouldn’t be the issue here… According to handy’s documents what I encountered was either “Machine is stuck” or “Calibration error”.

I’ve only had one time where the device’s LED flashes though. However these scripts do fail consistently when they’re played via handyfeelings.

One uneducated guess… handy’s server misinterpreted these scripts and sending out positions beyond handy’s stroke limit?

dunno maybe? For now i’d wait until either a new FW is coming or just stick with BT

All software, websites, etc., that use wifi loading, must go through the handy servers to load to your handy. The handy servers translate a funscript into a csv before sending to the handy, this could introduce a problem. The new handyfeeling website allows you to manually convert funscripts to csv and you might try converting these scripts first and then running them. If you run a csv it bypasses the conversion step and just sends the file directly to the handy (although the manual conversion should introduce the same error you should still check). If you still experience the same error I would then check/compare the funscript with the csv in a text editor for any obvious errors (labor intensive but easier if you know the exact time the error occurs). It’s possible the funscript has a small error, like an extra comma or number, that OFS and bluetooth ignore but throw off the server csv translation.

That’s just my guess but could be a good place to start troubleshooting.

Update: Turns out you can adjust the handy’s stroke range on I performed reset there and aforementioned script works again. Problem resolved!

You can also adjust the range on the handy itself. Short presses controls the top range, long presses controls the bottom range.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.