SR6 + Motor Controller - Issue with inverted axis

I hooked up a motor controller (specifically a L9110) to an ESP32, trying to get vibration control working, using the SR6’s code, but ran into an issue.
Now, I did get it to power the vibrator and i can control the speed of it, but for some reason the signal for 0% makes it go full speed and 100% turns it off by default. I’m aware I could just invert the V0/V1 axis in the scriptplayer, but it is pretty annoying to have it start powered on when plugged in and not paired…

Anyone got an idea what might be causing this?

Here’s how I hooked everything up:
MotorController_Wiring
(The ESP32 is connected to my PC with the micro USB. Forgot to add that in the image…)

I already tried the signal cable in A-1B instead and I also tried connecting the DC-motor to to the B-Port (with the signal cable in B-1A/B-2A) but the issue persists.
The D19 pin on the ESP32 (would be the V1 axis) also does the same thing.
It’s also not an issue with the script player/other connected software as this happens even when the ESP32 is just plugged into the USB and not connected to anything yet.