Struggling to use SR6 with SLR website

Hi, hope someone can help me here! I’ve recently changed up basically my whole VR/scripts setup. I’ve gone from using DeoVR on a Rift S and a Handy, to using Heresphere (switched to Heresphere largely because it has great SMB connectivity) via MultifunPlayer on a Quest 2 with an SR6. I’m still coming to terms with the changes but getting there, and basically loving it.

I mostly stream scenes and scripts from my hard drives, but would occasionally like to stream scenes and scripts from SLR (which I have a full scenes and scripts sub for). I realise that I can’t do this via Heresphere (I’d love to be proved wrong on this!) so last night I tried to do it using DeoVR and I had various issues.

Basically, any time I connected MFP or Xtplayer to DeoVR and tried to play a video, DeoVR would either crash and shut down immediately, or just get stuck in a black screen when I started to play a video. SLR’s website suggests using JoyFunPlayer but that seems to only work locally (ie with apps running on the PC itself). I have of course enabled remote control, and tried both with and without the haptics connection on (I must admit I’m a little confused by that one). nb I have checked and the app crashes whether or not it actually has a script. As soon as I restart the app, and it’s no longer connected to MFP/Xt it just plays perfectly well.

So yeah the TL:DR is that MFP and Xtplayer crash Deovr, and they would seem to be my only hope of connecting my SR6 to the app

I’m using DeoVR, JoyFunPlayer and OSR2 without any problems. Make sure you have the newest version of JFP, 4.0.0 as far as i know, where you can login to SLR.
If you want to use MultiFunPlayer, i think you need @Yoooi 's patreon version where you also can login to slr, but not sure in that point.


Start DeoVR first without connecting MFP/XTPlayer.
Start a random video, open video options.
Somewhere on the right side there should be a setting called “Android overlay (BETA)”.
Disable it and you should be able to connect after that.

If you want to use SLR script streaming then yea you have to either use JFP or patreon MFP.


Hey thanks so much to the pair of you, I’ve got it working with JFP 4.0 (I had the 2.0 from SLR’s website, and I hadn’t disabled the Android Overlay Beta).

@Yoooi I shall join your Patreon very soon, even if just for a few months, as I really appreciate your software and the work you do and the help you already gave me on Discord, I’m just a little concerned about the monthly outgoings creeping up with all the Patreon subs. I think the Patreon build will be right for me when I get the chance to really sit and look at it in the next few days (for a start, I use it for Heresphere already and it’ll be nice to have everything consolidated).

While I have you, I have a little question about MFP: is it possible to save different profiles? ie different T-code settings etc? Might be nice to have one with twist going wild for PMVs and one with it low/deactivated for the likes of VREdging vids etc. If this turns out to be a feature of the Patreon edition then my fate is sealed :rofl:


Yea you can configure pretty advanced shortcuts where for example when you press 1,2,3… keyboard button (or mouse/gamepad buttons) a bunch of settings change. Tho there are no automatic “per video” settings so you have to press the assigned profile button each time you want stuff to change.

For now only SLR script streaming is patreon only.

1 Like

Ah yeah, I’d sort of like to avoid having an extra device lying around as I use the SR6 in a different room lying down, though maybe I could connect an xbox controller or something. Are the different profiles easily accessible via the main interface? (As I have started keeping a tablet close by with TeamViewer for any interactions with MFP)

There are no real profiles (yet?), you have to configure multiple keybinds where each sets specific settings, and this kinda simulates profiles.

We are getting off topic so hit me up on discord if you want.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.