syncXplayer (Testing Version V0.3.0) : Experience Interactive Videos with Funscripts in Your Browser!

What is syncXplayer?

Yet another wheel … :laughing:

syncXplayer is an simple web browser that can connect to your toy , its for free.
When you browse a video link in syncXplayer, such as pornhub.com/xxxxxxx, it automatically matches the script for the video and powers your toy to start working.

You can also open local videos with syncXplayer, it will match the script base on the video file name.




How to connect your toys?

syncXplayer integrates the Intiface engine :+1:.
Simply click “start” in to begin connecting your device.




How to match scripts?

syncXplayer uses data from the “Free Scripts” on EroScripts.com to automatically match scripts as you browse video websites.
If you access EroScripts.com within syncXplayer, you can click on the video links in the posts to start playing them directly.




Applicability

  1. Currently, only Windows is supported, but there are plans to support Mac and mobile devices in the future.
  2. Currently, only single-axis scripts are supported.
  3. syncXplayer is just a single-tab simple web browser, I don’t recommend it for general use.
  4. This is a very early version, may be many issues. Please feel free to provide feedback at any time.




**Download syncXplayer **

https://filedownload34652.blob.core.windows.net/download/syncXplayer_0.3.1.rar


04/02/2024
V0.3.1
Remove the FireBase dependency.

10 Likes

file error when you click syncxplayer

First post? Access to Eroscripts within the program? This is kinda sus.

it seems sth wrong with file.io , i have changed the download url , pls try it again …

LOL ! I can understand you.

Initially, I only wanted to create a chrome plugin, but it has limitations when cross-platform .

So, I changed to an all-in-one solution that can be compatible with my Quest 2 in the future :eyes:

When a developer/company creates something useful that the community needs and offers it for free. It is a great way to get me to pay for their other services. Good form.

That being, it doesnt appear to be working for local or the two other web based options. I have only briefly played around with it, I will keep trying here though. Well done and thank you. We appreciate it.

1 Like

I got this error. I have been having GPU issues lately, it could be a problem just on my end. Im going to reinstall my drivers now.
image

I have only used it on two computers (win10 /win11), if you still have any problems, please let me know, better with the operating system info.

Sorry, it’s windows 11. I did get that error again after reinstalling GPU drivers. None of this looks relevant but here is the console anyways.Still not getting any playback in handy. Neither playing locally, through the hub or through eroscripts.

yeh i dug around a bit, found out how to get dev tools open. Used a debugger to snoop around. But i didnt have much drive to put any real work into it.

And the executable no longer wants to show a visible window but it is running in the background. This persists through a restart, and multiple gpu driver cleaning and reinstalls.

Another major issue is there is an app/service called syncXplayer actively logging my location. Which Im not happy about. There is absolutely no reason such a product would need my location and no reason it would need to enable that without the end users approval first.

I think given all of this negative feedback and the other circumstances you should just share the decompiled or raw source code on github so people can build from source as they see fit. Where they can examine it for anything malicious. There is no money in such a tool at this point in the game either. A developer would only really do it for the clout/stars on github. There are free options that are simple enough to use that it doesnt make sense as SaaS or some other form of paid product. You would need something unique. I dont even agree with paid VR video players.

I know open source is a shitty way to make money. Ive been there and am there. But this is a disaster of a beta/launch. I think it is your only option. After finding it actively on in my location settings I am no longer really willing to try this without seeing the code. Sorry.

If this is legit software and just a bad launch… well… Ive deployed crap too. So i feel for you. its a crappy feeling. but it is what it is man. Nothing worked and it came off shady as fuck.

1 Like

Hi , @IIEleven11 , I’m sorry for any trouble you may have encountered, and appreciate your feedbacks . :+1:

This is indeed an initial version, and there might be some issues that I haven’t discovered yet. I have changed the post title to “Testing Version.”

Regarding the location permission issue, I have considered two possibilities:

  1. The web page being browsed utilizes location services, but in syncXplayer, a prompt should appear, requiring manual confirmation.
  2. My dependencies include Google’s Firebase, and some modules within it might use location services. Considering that I am currently not utilizing any Firebase functionality, I will try to remove it.

syncXplayer does not have any background running, auto-start, or keep-alive modules. From a functional perspective, they are not necessary. Clicking the close button should completely shut down the process.

The software uses the built-in WebView2 component provided by Windows to display web pages. There might be “Microsoft Edge WebView2” processes running in the system, which are managed by Windows itself.


Regarding open-sourcing, not all code, especially the messy parts, may be suitable for showcasing now. Once the functionality is stable, I will consider hosting it on GitHub.

Yeah man, I understand. Yeah I didnt get any notification.I do have edge disabled though. Or thought I did, I was suprised it was using an edge browser when I opened dev tools.

I dont mean to come off like a jerk either. It’s just a dispersed binary gives an end user a suprise when they see its running with no window and actively reading location. It’s naturally going to make someone mad.I understand though how that could also be in part to how edge works too.

If i may suggest a chrome browser instead? Even firefox, you can package them up with the software, you wont have to deal with microsoft and edge this way.

1 Like

Hey , I understand how you feel. May I ask what software you use to monitor location request on Windows? I have removed the some dependencies in software , and I will recheck it . On mobile platforms, permission management is more explicit. The Android version currently only uses the “Discover Bluetooth devices” permission.

WebView2 is a recommended embedded browser component for microsoft. It is designed to share the system’s Edge browser engine, thus avoiding additional dependencies. However, it may be some trouble for users who want to completely disable the Edge browser. I will try to find if there are other solutions available on Windows.

For Android/iOS apps, most developer usually use the system’s built-in WebView, which helps reduce the app size.

I am working on Android compatibility, including VR headsets, and there is hope for the next version syncXplayer to run on Quest2 and Android Phone :slight_smile:

I am not gonna lie… i really like the idea of this!
I like this, because it uses initiface, meaning bluetooth, meaning FAR less latency then with websites that utilize the Handy connect code, meaning wifi.

I might be missing something here, and perhaps there is already such thing that exists, like websites utilizing bluetooth, but afaik, this doesn’t exist for free.

Haven’t tried it yet, but will try it soon ^^

Sadly the handy isn’t moving, even though the software claims, that it loaded the script successfully, other then that the device appears to be connected correctly in the building initiface part of your program. Big bummer, hopefully you can fix it :smiley:

Oops! My bad! :sweat_smile:
I’ve indeed found a bug in the previous version that hinders device connectivity, and @IIEleven11 may have encountered it as well.

I’ve fixed the bug and conducted multiple tests on Keon. Please download version 0.3.3 to give it a try.

Windows:
https://filedownload34652.blob.core.windows.net/download/syncXplayer-0.3.3.rar

It just popped up in my taskbars system tray it was like a little arrow iirc. Hmm yeah i’ve done a lot with browser stuff and never really had an issue using the chrome driver headless or headful. Might be something worth looking into. You wouldnt have to deal with all of this stuff with it because it just comes as a bare bones driver. Thatd be cool to run it on quest/VR, the current solutions are all mediocre

It works! couple things though

  • This time there was an annoying windows virus alert. I usually have my UAC all the way down. Trying to revert it to allow it to download may be a pain for a less technical person

  • scripts connecting to sites like mega.nz and pornhub work as expected. Other sites like bunkr not so much.

  • Playing local videos and scripts kind of worked. Certain videos would be able to link to a script and work just fine. others wouldnt be able able to find the matching script but would still play anyways. Then some would not find the matching script but still play and do like a half speed thing maybe? it was kinda following the script bet delayed and heavily slowed down

works well with the keon but i have a question i know you play local videos with local scripts but is there a way to play online videos with local scripts? if not is there a possiblity to ad this

I tried it out last night. My handy connected with no problems. But I had a couple of things to ask about.

The first thing was when using it with online sites, how do we know which of the videos have scripts. A script was always added… but they were the wrong ones. I tried to find one through by randomly choosing videos, but didn’t find any.

The other thing was that when using it locally it would fing the script with no problems. But the handy didn’t move up and down when trying to play. It just stayed in place and shimmied.

The concept is great. It’s easy to use.