EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Warning to those who play with the script players settings

Long story short I messed with my players min/max settings while it wasn’t connected to the Kiro as it was charging. Next day my Kiro would twitch when it connected but fail to run the script and I only got lucky to find in the butplug/server a error message about the command needing to be between 0 and 99 thus I had to go back and fix the setting I had changed.

Now the long version. Sat down to use my Keon Tuesday morning befor work and the dam battery died before I could finish (for some reason you can’t recharge the battery unless it’s under about 30%, probably to help keep it from forming a memory but it has no indication of its current charge so odds are good I will miss the chance to charge it once in a while). So I finished in “unpowered manual”, hooked it up to charge and started to play with settings in the player as the script had a few hiccups it couldn’t keep up on and I was hoping I could just tweak the speed setting to help.

Found the min/max and moved it from 10-90 to 0-100, and a speed setting I figured I’d play with next time.

Today(Thursday), again sat down to play before work and the kiro twitches once like it does when connected but then refuses to play the script. Odd. Figure it’s a new script, maybe has issues so I tried another new one. Again, nothing and it crashes the player. Concerning. Tried a proven one from before. Still nothing. Shit, is it broke? Switched it to manual control and it will move so the motors are OK. Do my deal, clean up and start trouble shooting.

Now I forgot I messed with the settings so I’m restarting programs, reconnecting, testing the bluetooth, everything I can think of and nothing is letting it do more then a twitch. Start a full reboot of my PC.

In the mean time I fire up the app on my phone and can get a script from PH to run so now I KNOW it’s not the Keon. Maybe the player or Butplug server program got updated.

Reboot completes, get everything connected and Keon still lays there like a prom date with no experience. I know the player updates every time it’s opened so if that’s the issue I would have to change players, move to the butplug server and while looking for an update button I find a notes section and at the bottom is an error “command above 99, commands should be between 0-99”.

Think to myself, what would cause that? Then I remember the setting I played with days ago. Find it and while it says 10-90 I figure something is off so I set it to 20-80, reset the Keon and software, AND IT MOVED! Now I can go back and see just where I can set that to maximize its abilities without crashing it.

You can’t charge it unless it’s under 30% and it doesn’t tell you it’s current battery level??

That sounds like an incredibly frustrating combination that leads to it cutting out mid session all the time, as well as it being a real hassle keeping it topped up. I was going to buy one, but now I know better! Thanks for the heads up.

Yeah, I bought one on a whim while getting something for the wife. Found out when I tried to register it they also don’t seem to cover the warranty if it’s not bought from their website.

If I try to plug it in too soon it just flashes like it’s full, I can use it 3+ times for over 20 min each before it will let me charge it and it supposedly can run for 2 hours, but that would depend on the speed/stroke. You also can’t use it while charging (although I did see where someone modified theirs to run while plugged in).

I’m not unhappy with it but it definitely has some design problems.