Fun Expander 2.5.2 - Video converter with ffmpeg to i-frames added [Updated 2022-04-11]

Ok. Well…I am SUPER LATE coming upon this. All the cpu talk confuses me so I avoid it. Anyway, I think this is exactly what I need. And I think this pertain to my issues scripting with JFS. If it is obvious or it doesn’t pertain, forgive me. I am NOT a cpu person AT ALL…so a lot of this is just confusing and I am just guessing.
So my issue is this:
Scripting higher res vids…and sometimes even lower res vids is so…I don’t know how to explain…it isn’t fluid. It isn’t on all vids, but some. AND IT IS FRUSTRATING. I can’t move frame to frame, forward or backward, quickly. There are delays and just pisses me off. It doubles or triples the scripting time.

So this expander…is that what it is for? To address this?
Again, I apologize if it is obvious. I am just tech ignorant.
And if so, could someone be a sweetheart and guide me through the setup and exactly what I need to do?
Much thanks in advance for any help.

The latest files you got from me that end in “i_frames” have gone through this process. If they work well for you, then this is the solution.

Yes. That is the case EXACTLY. I have ZERO issues with the Naomi vid. Man, I am wanting to slit my throat with some of these vids. One I just wrapped up…I think it was a PMV from the link you gave for all those PMVs. Man, it is not 5 minutes. Scripting the beat…to begin with…and it is taking twice as long as it should.
So, I DL the expander and the ffmpeg folders. I installed both but then uninstalled because I didn’t know what to do. I still have the installation folders.
When you get time, you think you can walk me through the process to get these things in i-frames?

Sure - hit me up on discord.

1 Like

Hey dude,
I originally had ffmpeg in folder on my D drive, but tried copying the parent app folder and all its contents including bin, doc and presets onto my C drive and using that location in Expander with no joy :frowning:
When I select a video to convert, it almost seems to boot the command then immediately close - don’t know if this helps at all.

Thanks for replying and trying to help :slight_smile:

no, sorry, i have no idea what could be causing this.

Try removing whitespace from the folder names in the new ffmpeg path if you have any. Improper handling of whitespaces is a common issue in many applications. It might not be the case here but it’s worth trying at least.

1 Like

You might try my version of ffmpeg, it 100% works for me. I know that some people had problems with a certain versions of ffmpeg and it solved the issue. You just need to download the “ffmpeg.exe” from the “bin” folder, rest is not important:

2 Likes

This fixed my issue!!
Thanks so much @Husky! You’re a hero :slight_smile:

1 Like

Hi!

Been trying to use this program, and everything works fine… the new “i-frames” video is created. However, I had already started scripting a video before I started using this. So I copied the .funscript, renamed it, opened it in the new video, and noticed all of the timing is now slightly off. Then I noticed the video itself is also slightly longer after being converted (less than half a second). This means that the reverse will also be true… if I script in the i-frame video and then apply that script to the main, the timing will be slightly off there.

Is this normal? I’m sure I can just adjust all of the points after applying the script to the main video, but since this hasn’t been mentioned, I’m assuming something isn’t working correctly for me. There was a question asked somewhere above about whether this conversion would affect the sync and the answer was a sure “no”.

edit: just tried again on a separate video. In both cases, after converting to i-frame, the previously scripted action now slightly precedes the visual action. Enough to be very noticeable. If I select-all and then shift right, it ALMOST lines up but not quite perfect. If I then save THAT script and apply it to the original video, now the script action slightly follows the visual action. If I select-all and shift left, it lines back up. This is doable like this, but certainly not ideal.

Strange, I’ve never noticed anything like that. Just double checked on my current project and the videos are frame by frame identical. Maybe someone else has an idea?

I’m going to try with a different version of FFMPEG and see if there’s a difference. Just based on your reassurance here I’m sure it’s something like that. Thanks for the reply!

Welp, I tried using 3 different versions of FFMPEG, including the one @Husky linked above, and all have the same result. I’m also checking the 30FPS box if that makes a difference. I’ll probably try without checking that later, but don’t have time right now.

edit: just tried again without checking the box to convert to 30fps. Now the sync is good and the videos are the exact same length. Unfortunate but I guess I’ll have to stay with 60fps unless anybody else has a fix.

New version of ffmpeg (full, not essentials, available at Builds - CODEX FFMPEG @ gyan.dev), had some errors, did some digging. Directions for use that I found that worked:

Windows
You are going to:
Open the cmd prompt by typing cmd into the search box in the task bar.
Change the path to where your ffmpeg.exe is located.
Change the path and file name to the file you want to convert.
Change the path and file name of the output file

Enter the following information:

[Drive letter of where ffmpeg\bin\ffmpeg.exe is found] [EXECUTE]

[Origin of ffmpeg - rt click ffmpeg.exe & copy as path] [SPACE]

-i [SPACE]

[Origin of source, copy as path] [SPACE]

-filter:v scale=2048:-1 -g 1 -qp 30 -acodec copy [SPACE]

[Destination, file name complete with path][EXECUTE]

Example

C:

“C:\ffmpeg\bin\ffmpeg.exe” -i “C:\MyScriptingFolder\source_video_file_name” -filter:v scale=2048:-1 -g 1 -qp 30 -acodec copy “C:\MyScriptingFolder\desination_video_file_name.mp4”

You responded to a 2 year old post. Does your post add anything new compared to the resolution in the discussion after my post (i.e. replace -intra with the -g option instead, which is implemented in Fun Expander)? :confused:

1 Like

Sorry dude,

The other change was the removal of the requirement for quote marks around [“scale=2048:-1”].

I use your excellent post to copy and past the text first into a notepad then into cmd but it stopped working when I re-installed ffmpeg on a new machine, took me a while to figure out why. I have tested the text in my post and know it works, and wanted to share.

I’m not overly familiar with working in plain text, so figured breaking it down would be user friendly if others are struggling similarly.

Apologies for necroing.

2 Likes

No problem :slight_smile: I was just curious if there was something special that had happened in the latest versions of ffmpeg that no one noticed yet.