EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.


Fun Expander 2.5.2 - Video converter with ffmpeg to i-frames added [Updated 2022-04-11]

For the basic functions of this tool look at my older thread:

New function:

Download FFMPEG from HERE

Convert your videos for scripting with JoyFunScripter 0.13.1 - Make your own scripts! to i-frames by FFMPEG. That makes scripting in default mode (frame by frame) a lot faster, because the compression will be removed and the single frames are shown instantly.

  • Enter the path of ffmpeg.exe on your system under ‘ffmpeg path’ or browse to it by click on the button ‘…’
  • Set heigth and/or width for the output video, if you want to change it or leave both checkboxes to automatic for original resolution

The conversation will be done in a separete command promt, which closes automatically after termination. You can find the new video in the same folder as the original.

ATTENTION: The converted video will be bigger than the original and it will take a while to convert (a few minutes up to hours, depending on the size and resolution of the original video)

Download from Mega Version 2.4

New Version 2020-11-24:

  • nothing has changed in functionality
  • inproved json (de)serializer to prevent mistakes while reading or writing

Download from Mega Version 2.5

New Version 2021-02-19:

  • Bugfix: Closing while minimized will not cause problems any longer
  • You can now convert your video to 30 frames per second:

Download from Mega Version 2.5.1

New Version 2022-04-11:

  • Compatible with ffmpeg V5 (command “-intra” replaced with “-g 0”)

Download from Mega Version 2.5.2



for ease of storage the script should still match the non-converted video correct?
So once the script is done I could delete the converted video since it is a larger file size?


@Dungeon_Master yes, the funscript matches to both video files and you can remove the larger after finishing the script.


just finished converting a vid and trying it out in JFS, WOW, scripting is back to being fun again :smiley: fantastic!! thanks a ton :+1:t2:


let us know how it goes @Ricster89 !!! :slight_smile:

I fixed it, was just me being a dummy :grin:

will this tool make scripting much easier/faster for you, @Ricster89 ?

Yep, it 100% does :+1:

1 Like

New update with a smal bugfix released!

The problem (if you are interested):

1 Like

Thanks a bunch!

1 Like

New update to version 2.5 released

Any chance to add batch processing? Would be nice to convert my entire scripts folder at once.

That is not planned at the moment. Maybe someday. But I can’t promise it.

Greetings and thanks for this program!
I had not tried to use the Convert video to i-frames until yesterday and have an issue or something. I have the ffmpeg path set. Then I press the convert button, navigate to and select my video.
The ffmpeg opens and processes and appears to save the new output. The problem is that windows nor other programs can see the file. I can only see it in the Converter select a file window. Somehow it is hidden from Windows? Any ideas would be appreciated.

Sorry I do not quite understand. After conversion, there should be two video files, the original *.mp4 and the new *_i-frames.mp4. You can’t see them in windows, but in fun expanders open file dialog?

1 Like

I can see the original which is there when I start.
The file _i-frame.mp4 does not appear. If I open the convert dialogue to select a video after the original conversion, it is there. But the created file is not there to see with any Windows 10 directory viewers or other programs.

Did ffmpg has write access in the destination directory? Try Fun Expander with adim rights and give ffmpg also admin rights.

1 Like

I ran Fun Expander as admin first and no improvement.
I checked the ffmpg and a far as my knowledge goes it has write rights. Anyway it works with other programs. Still no fix.

I remember some program similar to this that I used that did not work until I downloaded an older version of ffmpg. Cannot find the thread for that program or which versions worked and which did not. I may try that later.

Try ffmpeg from the command line and see if that works for you. See How to get started with scripting and go down to the section called How to improve performance when stepping frame by frame in JFS.

This is the interesting part:

Use the following command line after changing paths and video file names:

“C:\ffmpeg\bin\ffmpeg.exe” -i “C:\MyScriptingFolder\source_video_file_name” -filter:v “scale=2048:-1” -intra -qp 30 -acodec copy “C:\MyScriptingFolder\desination_video_file_name.mp4”

Change the path to where your ffmpeg.exe is located.
Change the path and file name to the file you want to convert.
Change the path and file name of the output file.

If this doesn’t work then something is really fishy with your computer.

1 Like