How to use scripts in VR - picture guide (Heresphere / Whirligig)

The same folder DeoVR uses should work, Interactive I think. Might also work in the same folder as the video.

What are you supposed to put in the “Connection Key” field if you are using a Lovense?

Try to follow this comment:

Lovense devices aren’t natively supported in HereSphere right now. I think you can use the timestamp server in the HS user settings with ScriptPlayer, though. Go to the HS user settings, enable the timestamp server toggle, and also press the icon next to the IP address input box if you’re using the Quest 2 standalone version. In ScriptPlayer, input that IP address into the DeoVR options, and then use the DeoVR player setting in ScriptPlayer.

1 Like

I followed the instructions and got the videos to play in HS (Quest 3). ScriptPlayer also has DeoVR shown as “Connected”. When playing the video in HS, the ScriptPlayer is synced, shows that video is playing and the timing indicator in SP follows the timing on the HS video.

My Keon also shows as connected through Intiface like normal with lights indicating also that it is connected.

However, none of the scripts are playing. Keon does nothing. Tested multiple videos that have worked before with my old cardboard streaming setup and Keon did not have any movements.

Anyone have any troubleshooting ideas?

If you’re using the HS timestamp server with ScriptPlayer, you’ll need to make sure the script folder has been added to ScriptPlayer’s path settings so it knows where to look for scripts. If you’re using XBVR as well, then you need to download the scripts from XBVR so they’re renamed to match the title of the scene.

However, I’d just recommend using the native bluetooth features in HS if you’re using a Keon. Make sure you’re on the latest version of HS (v0.9.7), click on the synchronized peripherals icon (looks like a play button with radio waves above the seek bar), enable the toggle, click on “Scan Bluetooth Devices”, accept the requested permission, and your Keon should connect. Make sure your funscript is in the same folder as the video, and has the exact same name except for the file extension.

1 Like

Thank you! That worked like a charm! Didn’t know you had a direct support. You just got yourself another customer :+1:

Hey there, I’m trying to follow all of this, but is there an easier way? Finding IP addresses and I don’t even know what SMB or XBVR means. I used to be able to run initface, start server, open scriptplayer connect to KEON by “connect to device” and then either drag and drop the video and script or open it up and all was fine. But then Whirligig did some sort of update and I could never get it to work again. I tried connecting it with DEO, but I could never get it to connect. Is there an easy way? Would it be easier to just use the cable? Would that cut out having to use ports and changing IP’s and everything? I see conflicting stuff here. One person said you can just download HS (I did figure out that meant heresphere)!. I can download it in the oculus, but then I read it has to be sideloaded. I read it can be downloaded to the PC. Here I am thinking I could just connect virtual desktop and play a video. I don’t understand why it’s this complicated. I was using faptap for a while, but VR vids wouldn’t run unless I had some special VR browser. If you can help, please let me know. Perhaps there’s a specific guide for my situation? I don’t have a quest. I’m working with an Oculus Quest 1. I can connect with the cable, or use airlink. I can get scriptplayer and initiface on my PC, I know how to install those. I know there’s a drop in clarity, but if it’s easier to connect, I’ll deal with the quality loss. How did the faptap creator make it so easy to connect? Hit connect, bluetooth, click keon and off you go with the video and script. Is there a way to connect using virtual desktop and then something like scriptplayer? It sounds like I need to first figure how to get HS onto the Quest 1. Any help would be greatly appreciated.

If you’re using the Quest 1, then I’d recommend getting the PC version of HereSphere from Steam and using Virtual Desktop, Airlink, or the Link cable (if your graphics card can decode and encode ultra high resolution videos). There’s a download link for the free demo on the right side of the HereSphere steam store page, so you can test to see if it works. Go to the user settings in HereSphere and enable the timestamp server toggle. In ScriptPlayer, use the DeoVR player option. It should work with the default settings.

This is probably going to sound like a really dumb question, but I’ve never used this before, so please go easy on me. I downloaded Heresphere from Steam. When I launched it, a box opened up with the HereSphere home screen. How do I get it to stream to my device? Do I have to go through Steam VR? For some stupid reason, something is wrong with my virtual desktop and it won’t open. It keeps telling me there are things causing it not to open. My antivirus software, which I’ve used for years and virtual desktop never had any issues with it. There’s something called punkbuster. I think I found a game that had it, but I don’t know. The file where it told me to delete it wasn’t there, so I just deleted the whole game. The 3rd thing is something with GEforce overlay. I’m working on that as we speak. I swear, something just does not want to let me enjoy myself.

If you have issues with virtual desktop, you can use airlink or the usb link cable (there are plenty of tutorials online on how to set that up). HereSphere requires SteamVR to run in VR mode, so make sure that’s also installed (maybe try manually starting it before running the app).

I was able to get HereSphere running and virtual desktop working. I’ve opened scriptlayer. On HereShere, I enabled timestamp server. I don’t know what the heck I’m supposed to do next. I can’t run DeoVR if Virtual Desktop is running. Or maybe there’s a way and I just have no clue how to do it. It tells me I can only run one app at a time.

You need to select the DeoVR video player option in ScriptPlayer (not actually running DeoVR itself). Click on “Video Player” near the top left of the ScriptPlayer app, then select DeoVR. You should see a message in ScriptPlayer that says DeoVR Connected (given that both HereSphere’s timestamp server and ScriptPlayer’s DeoVR settings are on default). You might need to restart ScriptPlayer or toggle the TimeStamp server off/on in the HereSphere user settings until you see the connection message.

I recommend reading the first post in this thread for more details. It explains how to set it up in depth.

Sorry if you’ve already covered this many many times already. I’d like to be able to connect my keon to heresphere via the virtual desktop method so i can use the extra juice from my PC to play some higher quality videos. Does the PC version only have direct handy support? because I also have it on my quest and can directly connect it to the keon that way. Or do you have to go through the outlined original post to connect a Keon via PC in heresphere.
Or am i missing something inside the HS steam app and should be able to connect it.

PC version doesn’t have support for native bluetooth devices, yet. You have to use the timestamp server with another app like ScriptPlayer/Intiface to get bluetooth devices to work.

No issues with setting up heresphere/timestamp server and connecting the script player to the timestamp server on the script player.

But - this is only a way to play local video’s then?
I’d have to open local media in the script player + fun scripts?

How do you get faptap working in Heresphere for example?

Thanks for this, helped me out.

New to vr funscripts, but not to vr. I have an old quest 2 that the controllers don’t work on. Is it still possible to use or do i need to get replacements?

Hello, I got stash-vr to finally show up on the here-sphere browser but when I click on a video it doesn’t play and the cmd prompt gives me the error [Failed to parse resolution from label error=“no reolution height found in label” label=mp4 mod=heresphere]. Any ideas on how to fix it? The standard smb server method of streaming my videos to my quest would not work so I decided to try out this method.

I’m also seeing this exact issue. Any time I try to load any video, whether it’s VR or not, I get this error:

WRN Failed to parse resolution from label error=“no resolution height found in label” label=MP4 mod=heresphere route=videoData videoId=1

I’m running stash-vr version 0.7.8 (latest), and I tried running it using both stash version 0.24.3 (latest) and version 0.23.0 (last known version that stash-vr supports). This was my first time setting up and using Stash-VR. I was able to get to it in Heresphere, and I confirmed on the local pc that it is running without any other warnings.