Kodi on TV + ScriptPlayer + TheHandy


maybe someone of you has or had the same issue and can help me somehow.

Watching Videos with ScriptPlayer (1.1.1) and connecting with TheHandy works all fine, but I can’t get any Script to run while playing the Video on my TV via Kodi.

This post helped me to figure the right steps…Thx to @gagax123 :+1:

And I managed to get it all work together when connecting to Kodi on my PC.

(I renamed the videofile and the script aswell, because I thought maybe some characters in the filenames could be problematic, although there are no problems when watching in ScriptPlayer)

So, I use the same settings, change the IP to the one Kodi shows on my TV and I get this

Has anyone an Idea?

well on what kinda device is kodi running ? has it also a vpn app running on it ? does the device respond to any requests like ping´ing it via terminal ?

Kodi runs on a Philips SmartTV with Android OS. No VPN. Responds to ping command.
Steaming videos from my PC works just fine with Kodi on TV.

ScriptPlayer seems to get the connection done. It says ‘Kodi connected’ int the center and as soon as I start a Video on the TV, the scriptposition on the bottom starts rolling.

Everything looks just the same, as when connected to a Kodi instance on the PC, but the scipt won’t load.

There is a strange scenario that I ran into while trying different things:
First I connect the ScriptPlayer to the Kodi instance on my PC, start a video, the script loads, Handy starts working.

Then I change the connection in ScriptPlayer to Kodi on TV. Connected…Start the same video on TVs Kodi, ScriptPlayer says ‘No script found’, but the Handy starts playing that Script anyway. I can even jump trough the video, the Handy plays the script properly.

But when I then start any other Video (via Kodi on TV), ScriptPlayer again shows ‘No script found’ but the Handy starts playing that one script from before (the one it loaded while connected to Kodi on PC).

since you mentioned you use the scriptplayer version 1.1.1 i would try the newest ““beta”” build. seening as 1.1.1 is … more then 2 years old :0

Oh, I didn’t know there were newer ‘beta’ versions. So I tried the newest one out, but it still won’t work. Maybe my network cofiguration is just messed up :smiley: Man, I hate that network stuff :sweat_smile:

Anyway, thank you for trying to help and the tip about the ‘beta’ version :+1:

I’ve done this before. It’s important to make sure that the script you are playing is in the same directory and named similarly to whatever media you are playing on the KODI system. Not sure how ScriptPlayer finds the script, but that’s what works for me.

That’s what I sometimes tend to forget, but I considered that in my attempts to make it work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.