New to this. PLEASE HELP

So… I’m having trouble on finding how to play these scripts. I’ve downloaded a bunch of links such as and still can’t figure this out. Can anyone explain in laments terms how I can get these scripts to play on my tablet n sync up to my Keon. And I’m not computer savvy AT ALL. U may have to explain it to me as if I was a dummy with computers and software.

Start reading this: How To Connect Your 147+ Sex Toys For Interactive 2D and VR! (Including the HANDY, Fleshlight LAUNCH, Kiiroo KEON, VORZE, LOVENSE, and more) Step by Step Guide with Pictures!)


I’m trying to watch it in 2D. SLR seems to be in VR only

Ok, I only play videos in VR and I don’t have a Keon. However, a quick search here in the forum and I found someone who seems to have managed to get it working. Have a look at it and see if you can get it going.

Still can’t figure how to get playscript on my phone/tablet. Is there a “playscript” app I have to download or something?

do you have a MAC? Did you try intiface desktop?

I’m using a Samsung tablet. My laptop is about 10 years old and don’t have a desktop cpu

you need to install the software “intiface desktop”

What you specifically need is dependent on what you want to do, but I can go over the basics and hopefully that will help you figure out what you need.

First, you need some software that can actually send signals to the toy. The most recommended app for that is going to be Initface-Desktop. Initface is just the nice, user-friendly version of You can think of those two as being the same thing, and they are built using the same code.

That software will allow your computer to connect to a toy, but it doesn’t do anything by itself. You’ll now want an app that will do something with the toy. This will usually be a 2d or 3d video player, or a game if you’re trying to do something fancy.

The easiest video player is probably Scriptplayer. It’s quite user friendly, and easy to install on desktop. Once you have that installed, you’ll want to check the settings under the buttplug tab and make sure the url shown there matches what’s displayed in initface so that the tywo programs can talk to each other.

Once both of those are installed, you’ll usually follow the process below:

  • Start the Initface App
  • Start the Scriptplayer App
  • Select Devices → Buttplug/Initface → Connect from the scriptplayer menu
  • Wait for a message saying “Connected to Buttplug”
  • Turn on whatever device you’re using
  • Select Devices → Buttplug/Initface → “Scan for Devices” from the scriptplayer menu
  • Wait for a message saying your device has been found
  • Use the scriptplayer menu to open the video and script you want to play

At that point it works like a regular video player with play/pause controls and such.

Hope that helps.

1 Like

Thank u. I’ll try n see if it works. I really appreciate the help

1 Like

Hi, I’m having a lot of trouble with this stuff too and I hope you can help me out. So I’m following your instructions so far and after I hit “connect” in the scriptplayer menu, it says “connecting to buttplug (attempt 1/10)”, and then the scriptplayer program closes itself a few seconds after that. I tried running it in administrator but it didn’t help. What am I doing wrong?

1 Like

I’ve had some issues with script player connecting using the latest version of Initface. I think it’s a bug that’s been introduced recently. Here’s a couple things to check.

In the settings for initface, have it use regular websockets instead of SSL. SSL should work, but you don’t need it when working locally. Also, make sure the server address in Scriptplayer is correct (default is ws://localhost:12345/buttplug).

You might want to check out the buttplug discord. The developer is good about offering tech support on there:

Unfortunately i think the crash issue is in ScriptPlayer, and the dev for that isn’t usually on the discord. You can report the issue on his git page though: Creating Issues to report bugs or request features · FredTungsten/ScriptPlayer Wiki · GitHub

Another thing to try is to install the beta version of Scriptplayer if you’re not already using it. It’s more up to date than the current official version.

I should probably update here lol. It was a mistake on my part as I didn’t know I needed to click “start server” in initface. I’m a complete newbie to this whole thing. It seems to work fine now and can connect.

1 Like

Glad you got things working! Yeah, I should have thought to mention that. I always turn on the setting in initface to start the server when the application starts, so I didn’t even think about it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.