EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

OSR2 Jittering and unable to support weight

I’m using 25kg servos and the OSR struggles to raise the arms even when there’s no fleshlight. It’ll jitter and barely move and when you put a fleshlight on it, it can’t raise the arms. Any ideas on how I can fix this? If I look closely I can see the servo moving but the arm’s don’t sometimes. I’m using the included 25T servo horn.

1 Like

Has it ever performed as expected or not?

Is the common ground installed?

What micro controller are you using: Romeo or ESP32?

At this point I still need more information to try and reach a resolution.

This was my first test run so no, it hasn’t performed properly since I set it up.

If by common ground you’re referring to the external power bus, I haven’t set that up yet.

I’m using the Romeo BLE mini V2.

I was planning to install the power bus later but it didn’t sound like it was required so I tested it without the power bus.

can you please share pictures of the circuit/wires and say which servo’s you’re using?

some servo’s are rubbish but it should still lift weight, if there’s no power the thing won’t be able to move the heavy fleshlight around but it should still be able to lift the empty arms

You’re powering the servos over the micro controller?
Mine only started working properly when I setup the external power bus.

Uploading: C673F35C-B5FF-43E3-89CF-3D3107F7E36B.jpeg…
I’m using Annimos 25kg servos

hi the image doesn’t seem to have uploaded correctly (I don’t use the powerbus for the OSR2 with 2 servos)


Here try this.

At this point have you successfully flashed the Romeo?

Yes, I’ve uploaded the script and everything. I was able to test it in the Arduino IDE so it should be working.

Does the device go to home position when plugged in?

When using JoyFunPlayer do you see CONNECTED in green next to USB TCODE?

Are you able to go to https://trymosa.netlify.app/ and connect to/control the OSR?

Side note/not related to your current issue: At the bottom left on the inside of the body of the OSR there is a hole that is capped off with some plastic you need to remove. It is intended for you to use to wire in the pitch servo.

Here is a link to to most recent instructions just in case. Discord

what ino do you have on romeo OSR2-Release3_3.ino or OSR2-Release3_4.ino?
what power supply are you using ? have you tried a different power supply ?
have you gone back through all connections making sure they are all the way in and made sure all horns are tight ?

1 Like

Good questions @Dimebag

So I tightened the servos horns and its working a bit better but it still weighs it down when I run a script. I’m using 3_3 and I’m using a 5v AC_Adapter. When the OSR2 is at home and off I can mount the fleshlight on but when I run the script or test it out with mosa, it weighs it down and it can’t go up until I remove the fleshlgiht.

1 Like

I think a more thorough check of the servo horns is worth doing.

Remove the arms and also the servo horns. Look at the teeth, and make sure they aren’t stripped. You can’t use a stripped servo horn no matter how tight you make the screws.

After that, power the unit so the servos go to the home position, then put the servo horns on as close to horizontal, and each other, as you can. Tighten them up, then try to move them up or down by hand with a little bit of force. You shouldn’t be able to move them without applying a large amount of force (don’t try if if they didn’t move before).

If all that’s working as expected, I’d use a separate power supply with a power bus before trying anything else.

1 Like

would try a new power supply as another user on discord had problems with it turning on fine then when started a script power supply would turn off so im thinking they are getting power just not enough from the power supply you have i could be wrong but from photo everything looks connected correctly other than cant see what ports/ orientation you have your power supply connector leads screwed down under your servo leads from photo above

A picture of the PSU wouldn’t hurt either.


I’m using this.

when you have it plugged in and run a script does the light on front of power supply stay on or does it turn off?
for a romeo board i would turn it to 5v imo
does the connector end have play in it when you plug it in the osr?
have a picture of the power lead connected to romeo (green bar)at bottom ?
are you able to move servos in the arduino ide with just the micro usb plugged in?
if none of those idk what else other than try a different power supply

Yeah, the power supply lights up.

Here’s the screenshot. It looks like it works when there’s nothing mounted on.

If you’re asking if I can move the servos without the power supply, then yes. It works.