Seal of Lutellaria - device integration

guys
he is horny

3 Likes

well i was talking about the integration mod & script that might have to get an update

do it match and apply well that newest update release? (2023.10.30)
just i wanna using it

Alright so I’ve updated my mod…but due to it being now 6:18 am for me now (been at least 3 hours of this) and I know I’m tired I have done NEARLY…ZERO, ZILCHA, NO TESTING of the mod to see if it all works except just starting the game and running it which at least showed that the systems except for the boss fight and looping area systems worked at least on the surface.

I do know though that through my sleep deprived efforts I couldn’t figure out all that @Nodude did to get the integration to work so sadly I did the best I could and then did a rework of the punishment system so it still appears to work but I suspect it’s a bit less accurate/on point as it once was as that took advantage of the code.
So for the latest version of the game to work with the Handy or other sex toys I’m afraid that’s going to be up to them or whomever got it working in the first place. However I did notice that some variable numbers have changed like hscene ones for specific enemies so it may require more than a slight fix.

Anyway here is the pixeldrain link and as always I’ve included there the changelog (it’s very short since I only updated and didn’t add much) along with the 3 screensize versions of the game: Lutellaria Mediumcore mod v2.7.5 No Working Integration For latest game version

Additionally here is the link to the mod version that works with the previous game version and thus does have the Handy/SexToy functionality so people don’t have to go scrolling a bit: Lutellaria Mediumcore mod v2.7 Integration Working for previous game version

PS you need to update more than just the data.win otherwise the game will crash before it opens so update your game overall!

2 Likes

any plans for a script update ?

3 Likes

It’d be a shame to let this die, so I’d like to add my +1 for this.

image
can’t detect tcode(osr/sr6)
it can only detect bluetooth now

I’ve been doing some light testing myself and I believe it’s an Iinterface problem since I found in the logs when I tried to see what the non-built in version said that it was disregarding the serial port despite finding it…needs more looking into before I can conclusively say that’s it as I only just got my SR6 and started looking at this while I’ve got some other stuff on the side now.

1 Like

OHHH OK I thought I was the only one. Yeah I cant connect my osr2 either

I turned off filler and saved. Seems to be working okay until I attack, then the filler starts again. It’s this a bug or intended feature?

I found sometimes stuff doesn’t save/go through till the integration app is restarted.

since the mod hasn’t been updated, if anyone is willing to script the new scenes please let me know so i’ll record them if needed

I cant find the latest update “18-01-2024” anywhere, i will check again at a later date,
probably.

For future me:
It would also be nice if i made a animation renderer so i could extract animations and fit them perfectly to scripts, but that hasn’t happened yet (see atlus and json with “bones” image).

is there a changelog for it ?
edit : here’s what i could find:
・Deleted the corresponding part because a room that did not exist was displayed on the minimap.
・Fixed because one of the doors in Area 2 was moving to the wrong destination.

Sent you a message with the last two versions of it.

Half good news to yourself and @hue04476.test1 or anyone else looking to get the OSR/SR6 working with this…as I made some progress by going to the intiface discourse forums and finding this Using OSR2/SR6 with current Intiface Central Version (~2.3.0) - General - Buttplug.io and Intiface® Support which after a quick test does work with sending movements to it however…it gets stuck I think…since after turning off filler and got sex scene to play I found that it didn’t stop playing nor switch to a new movement.
I don’t know anything/understand about intiface nor the player to know which is the problem but hey…I got some progress for those that like to have one motion play out forever more and connect to the device via intiface.

1 Like

Animations are no longer stuck in 1.08 (hopefully)

1 Like

Half fixed it as while it does stop getting stuck…in sex animations the SR6 I think maybe is able to go fast enough that it goes moves onto the next script part before the animation has done so. Resulting in some animations with fast to then slow bits having noticeable difference in SR6 movement and the screen. It can be minor but also sometimes major…similar to having more than a few hundred ms ping delay. It did take me a few watches to think that it’s the SR6 going too fast rather than too slow and getting left behind.

Feedback from attacks and other stuff appear to be fine and not sticking at all. (though again I only did a quick-ish test)

is this mod updated to the latest version of the game ?

Only the player related files were updated in the megafolder. Data.win file was not so I presume not.