EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.


XTPlayer - Cross platform TCode sync (OSR, SR6) Stream your local media and sync funscripts to almost any device with a browser


  • Multi funscript (MFS) support. See README in application directory for more info.
  • Load a folder with videos for easy access.
  • Built in funscript to TCode conversion
  • Load any funscript with any video
  • Customize the player looks via an easy CSS file.
  • Add multipliers (psuedo random motion) to TCode’s other axis’ via the current funscript pos
  • Thumbnail preview customizable or random
  • DeoVR sync
  • Whirligig sync
  • Gamepad OSR control
  • Web server with web video sync along with DeoVR Web browser support

That’s a great piece of software! Works very well. Would it be possible to save the settings and the selected library? That would makes it even better. Thanks for your hard work.


Thanks! That should be happening automatically on program close. Is it not working for you?

1 Like

No, i have to select the media library on every startup and the settings are lost. I’ve tried to run it as admin and also from different folders on my system. My system is Win 10, 64 Bit.
Anyone else here has this problem or is it working for you?


1 Like

That’s not cool! Wonder whats happening… Have you tried Reset All?
EDIT: Just spoke with some one that’s having the same issue on windows 8.1.
Something is going on for sure.

1 Like

Sorry for the alert, that was my fault. I moved the files in ‘XTPlayer-v0.13b\release’ into an other Folder called ‘XTPlayer’ without subfolder ‘release’, but this seems to be reqired. Now it’s working like a charm!

1 Like

Hmm it shouldn’t be required… Glad its working though.

1 Like

Nice program!

I’m running Win7 and it also isn’t saving at all. Not settings nor library folder. Didn’t move from folder release or reroute files.

1 Like

Thanks, I’m not sure whats going on because I cant reproduce it on any of my machines. Nor could some others. I am thinking of moving the saved settings to an ini file inside the application directory. Though, that would require the user to put the app in a place their user account is able to write to. Maybe AppData…

If you or anyone else with this issue is curious, the current versions settings are located in the registry under:
HKEY_CURRENT_USER\Software\cUrbSide prOd\XTPlayer

1 Like

No worries. Thanks for your work. FWIW, my registry entry contains just the default values. Predominantly 1s & 999s. So it looks like it never successfully wrote to the reg.

1 Like

It did write at some point cause there wouldn’t be anything there. Its just not saving for some reason.


New version out


For those of you having settings save issues. If its still happening try renaming the file


Your settings should go into this file on next XTP start.


New version 0.2b out. Updated OP with details.

I just tried to run the exe. No UI appears after the dialogue of the settings reset. I tried both overwriting the directory with the last version in it (overwriting files) and an install in a clean directory. No luck.

On Windows 10.

Well this DoesNotCompute…
Is it running in the back ground in the task manager?

Try running it with the debug bat file or
XTPlayer.exe -debug
in the exe directory. See if it outputs any txt file.

Put a settings.ini in the exe directory and see what happens.

You could also try running
XTPlayer.exe -reset
To reset all settings to default.

Yeah, the name I chose for here does kinda fit a bit too well. Here’s what I’ve done so far:

I tested V0.14b, that opens up without any issues. Also to note no Arduino devices are currently hooked up to the computer. And the controller dongle is hooked up but no controller is on.

I then cleared the folder and unpacked the V0.2b zip into the same directory. Before starting anything I renamed the settings ini to settings.ini

With task manager open, I try the exe, click through the windows protection, and the dialogue comes up about defaults reset. While the dialogue is up, the process XTPlayer.exe is active in the task manager. Once I click OK, the task goes away.

I tried the debug bat, clicked through the protection, the process shows up while the dialogue is open, but disappears when I click through it. The only txt files in the directory after are HOWTO and README.

I tried using the reset command (changing the bat file), and as far as I can tell a process flashes up and off immediately. From trying it repeatedly, I’ve traced it to a Skype sub-process (?) that is marked as “COM Surrogate (32 bit)”.

Edit: Uninstalling Skype does not stop the problem, and now the task that’s popping up is “Windows Problem Reporting”.

Edit 2: Checking the event log, the Error getting reported is Event ID 4311, and it starts out “Initialization failed because the driver device could not be created.” There’s also a lot of warning about Application COM permissions not being granted.

Edit 3: In the application logs, this shows up:
“Faulting application name: XTPlayer.exe, version:, time stamp: 0x5f964fad
Faulting module name: qtexttospeech_sapi.dll, version:, time stamp: 0x00000000
Exception code: 0xc0000005”

All the errors appear to reference that dll.

Interesting, I assume .16 doesn’t open either. I added text to speech in it I believe. Is there a text to speech dll in the application directory? I’ll have to get to my PC to see an exact location.

That dll is in /texttospeech

I noticed you said “click through windows protection”. I’ve never had to do this on any of my machines.

I hadn’t tried it before, but I just downloaded V0.16b4. Installing it in a new folder, and running gets the same result (immediate crash) and the same crash log (same dll reference).

As for the security window, I don’t know if it’s a Win 10 Pro thing, or if I just have a security setting on somewhere, but any “suspicious” application (or batch file) requires a user clearance before its first execution. It happens any time I’m trying to run anything from github or the like. It has not interfered with any other program’s operation before.

Edit 1: Deleting the text to speech folder allows the program to run. I get a bunch of warnings about svchost database format errors in the log, but the program comes up in both v0.16b4 and v0.2.

Wow thats unexpected. There’s a checkbox in settings to disable text to speech. All this does is skip those commands but it may help.

Edit: maybe try something that does text to speech like the gamepad speed or stroke range increase decrease. See what happens.